Solar production at night exported to pvoutput

Hi Everyone,

Recently I deployed Iotawatt and want to feed pvoutput from it. Currently I use python script to read some cloud api from another metering system to do the same.
Once I deployed it, I made test account in pvoutput and started comparing result.

Trouble is that I have night “production” of 3W reported on my inverter cable. After some diagnostic run, I found:

  • it is current in this cable as turning fuse off stops this reading
  • It is correct direction as it is the same as real production. I made it bidirectional and during minimum light it shows reverse direction of 5-20W but when inverter goes to sleep it remains solid 3W in production direction
  • It is certainly false positive as there is no energy in inverter at night.

I tried to alleviate issue by adding “(inverter -3) max 0”. This does prevent false power reading in pvoutput but energy reported by iotawatt still increases by 12Wh every 4h.

The only way I can explain this false reading is apparent power draw by some capacitance in inverter. As it would be turned 90 degrees, I can imagine further phase shift either in reference transformer or CT to be on the other side of 90 degrees making it wrong direction. However, this still does not make sense.

Any tips how to either fix, compensate or overcome this false reading?

Cheers,

If your three points are correct, it’s not a false reading. You say when you turn off the fuse, it goes to zero, and when you allow reverse it is still positive. Yet as you also say, producing energy in the dark would violate the law of conservation of energy.

So we have a paradox. My inclination is to double check the assumptions. It’s very common for an inverter to draw standby power. what I would suggest is that you set allow negative values for the inverter CT, and specify generation to PVoutput as
Solar max 0.

If the problem persists and generation during the day is positive, then post a plot of the inverter CT that covers both the night and day behavior.

Yep, I believe current is real just wrong direction found. This is why I thought it could be from reactance making it pf next to 0 and misreading direction by added phase shift made by CT.

It is already bidirectional and generation is positive when is real. There is also a bit of negative just before inverter goes to sleep.

I need to figure out how to put screenshot here…

1- close to end of light
2 - negative power while powered from grid
3 - Goes to sleep
4 - when I ticked reverse in settings
5. First light

Settings:


OK, position 4 convinces me that the configuration isn’t the problem. However, there is some current being indicated. What you posted suggests you are 230V single-phase. If that’s the case, 3W would be ten or so mA primary. That’s 10 uA into the IoTaWatt. Not even a high end multimeter would pretend to accurately read that in a 0-50mA range.

I suppose its possible that a negative standby current is being phase shifted positive, but that would require a shift of more than 90 degrees. I don’t see that as likely. My guess is that it’s noise picked up by the CT cable.

Can you try rerouting it away from high-voltage cables to see if anything changes?

That is already done. In fact I installed this CT on neutral cable but still the same. I think the current itself can be substantially higher as what it shows is real power. If pf is, say, 0.05 as current runs via capacitance, then it could be explained. Thing is for capacitor which is nearly pure reactance pf would be nearly 0 and phase shift v/a nearly 90 degrees. Then 5 degrees forward or 5 degrees back and we have either positive or negative real power from it which is false anyway.
I’ll check current alone in this cable tonight, let’s see what’s there.
Do you know what to put into “generic” CT setup for this CT? I could try play with phase shift then. BTW - this shows pf 0.99 for inverter while runs at full steam and inverter reports pf 1.

Tested, 0.46A when dark and offline. So it must be phase from CT. Does anyone know what to put as “generic” to start with?

Alright, I think I solved it but could save myself misery if I scrolled menu down.
I found what is used as embedded table for known inputs. Made CT “generic” and then shifted phase from original 1.0 to 1.7 until it got corrected. However, I also used “generic” reference trafo. As it may introduce shift to, I looked what is in embedded table and found that mine is actually listed. Changed it to “Powertech”, switched CT to what it is from the list and it seems correct for a while.
Tomorrow is another day with daylight, let’s see what will show up as now all CTs are shifted by 0.7 forward due to corrected voltage shift…

Half an amp is a lot of current for standby. Can you plot amps and var and Watts for the inverter output using Graph+?

That is power now

Complete


It must have some sort of filter with capacitance.

Power supplies and filters are outside my areas of expertise. Essentially your inverter appears to be drawing .5 Amp and then giving just about all of it back. It’s hard to imagine this not being a nightmare for power companies. What is the inverter brand/model?

On the bright side, IoTaWatt’s phase shift compensation appears to be working very well. While most electronic power meters are fine tuned for the shift of their fixed components, IoTaWatt uniquely allows using literally dozens of various VTs and CTs using table driven compensation values, and it appears to have worked extremely well here.

It is Goodwe GW10K-MS. Not many available with single phase 10kW.

Reactive power is a nightmare but is very common. Many switching PSUs are PF 0.6-0.7, dimmers make it even worse and lots of devices have filters drawing 10-200mA while they are off.