Solid red - dead?

It appears that my oldest unit has died. The LED goes solid red when power is applied and never changes. I’m hoping that I’m overlooking something since there are no replacements to be had.

Here’s what happened:

I added a 2nd unit to my main panel and decided to reorganize all the CT leads while I was at it. I successfully reconfigured all the inputs to the original unit and had expected readings from the inputs (I sure wish I’d copied config.txt at that point!).

To avoid adding a 2nd 9V wall wart I spliced in a lead to the new unit. I also switched the 5V power to a dual USB adapter. Somewhere in the multiple power-up operations the original unit stopped working and had the solid red LED so I pulled the SD card and found that it was missing all files/directories except /download so I reformatted it and put the stock files on it per

No change, still solid red. I tried a new SD card built as above and it’s still just solid red.

I’ve tried a separate power supply as well.

Is there anything else I can do? Maybe use the RST button on the 8266?

That sounds like the problem. When you use a common 5V supply, the units have the same ground. If the polarity of the shared AC adapter isn’t maintained, you create a direct short in the IoTaWatt units. Are you located in the USA?


So sharing the 9V reference is OK? I just need to go back to separate 5V supplies?

EDIT: Since the 9V is AC I made no effort to maintain shell/center “polarity”

What I recommend is using a 5.5mm CATV splitter for the AC. That maintains polarity. If you measure the voltage between the outer contacts of the two AC plugs, you will probably see ~9VAC. It should be zero with like polarity.

Yes, separate USB supplies eliminate the problem.

If you send the unit to me, I’ll see what I can do.

IoTaWatt, Inc.
92 Sewall Rd.
Wolfeboro, NH 03894

Include a copy of this post.

Sure enough. (Give me a 50/50 chance and I’ll get the wrong one EVERY time :roll_eyes:)

Thanks, Bob. You’re the best!

I’ll get it in the mail tomorrow.

Another thing though, the 2nd unit is reachable via Wi-Fi and appears to be just fine except that it’s not seeing the reference voltage.

I was thinking that it may be the loose solder joint issue mentioned in another topic but now I’m thinking you’ll have something to say about that as well.

I was wondering how it survived the short. Usually the TVS diode cooks, a 20 cent part. Better send both.

1 Like

Will do. Thanks

The unit with solid red led was completely fried. When I powered it up the ESP8266 got very hot. I had to replace the entire PCB - basically a new IoTaWatt.

The other unit had a TVS diode, ADC and Opamp. Tests fine now.

I put new SDcards in both. Sent you a Paypal invoice for my costs.



Again, Bob, you are awesome! Thanks so much for every-damn-thing!