Start/setup Fail

bob@iotawatt using Forum for contact as requested re ‘cracked SD card, my bad’.
C:\Users\dp>ipconfig ::

Windows IP Configuration

Wireless LAN adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : home
IPv6 Address. . . . . . . . . . . : 2600:6c44:393f:c876:0:6eda:d246:17b1
IPv6 Address. . . . . . . . . . . : 2600:6c44:393f:c876:d86c:2e9c:9b99:af08
Temporary IPv6 Address. . . . . . : 2600:6c44:393f:c876:cce3:c5d9:16b8:acca
Link-local IPv6 Address . . . . . : fe80::d86c:2e9c:9b99:af08%4
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . : fe80::bad9:4dff:fe2b:9cf0%4

Wireless LAN adapter Local Area Connection* 17:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::95bb:df48:611a:f04a%16
Autoconfiguration IPv4 Address. . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :


IPv4 > > “Unable to connect
Firefox can’t establish a connection to the server at”

Couple hours reviewing entire wiki before attempting 1st connect and then did ‘connecting’ step by step (at age 72 I study first).
9vm & 5v. >> brief green, pause, RGG . >>
Cellphone showed ‘iota12707449’ (not ESPnnnnnn) tried to log on (2.4Ghz) >>
Psswrd rqstd >> copied / pasted from wiki ‘IotaWatt’ >> Pswrd incorrect >>
Trblshoot rcmnd : IoTaWatt.local/command?disconnect=yes >> “Unable to connect
Firefox can’t establish a connection to the server at” (same as initial above never gets to config display shown in wiki >>
Tried many permutations and other suggestions. Occasionally RGG would go RRG. I pwr cycled >>
brief G pause RGG as initial.
Cracked SD removing to see files stored >> wouldn’t reboot >> RRG

Per your suggestion new SD (64GB SanDisk) cloned gits you sent to SD root >>
Still won’t boot but get RRG but / and don’t see a network on phone (or laptop).
Would like to send iotawatt unit back for eval / repair / qualification. Will hang on to CTs and wait for return. I will pay postage and inlude both SD’s (the broken and my clone).

Do I need an RMA or other? Please advise how to proceed.
I appreciate the help and apologize for the trouble.

You should still get RGG right after power up indicating the unit is not connected to WiFi. After about three minutes, if still not connected, it changes to RRG. To get RGG back you power cycle and get another three minutes to connect.

It’s possible something may be amiss, but I don’t see any indication of that. So sure I can test it, but I doubt there is anything wrong and it won’t change the requirement to connect to the AP and configure to your WiFi, so I’d like to see you exhaust all other avenues first. What kind of phone are you using and do you have another WiFi capable device to try connecting?

If you really want to have me look at it:

IoTaWatt, Inc.
92 Sewall Rd
Wolfeboro, NH 03894

bob@iotawatt : thanks for response. Image is of new microSD64GB using computer.I believe this is what you intended? Could 64GB of new be a prob, wouldn’t think so but can get smaller. On hand only 64’s and 128’s.


Powerup with new SD >> GRR which Docs describe as SD reader socket problem. Cycled several times and SD in / out multiple times for seating. Same GRR.

As Received G pause then switched to RGG indefinitely (20 mins+) or until some attempt to connect resulted in RRG then I would recycle but same results.
When 1st opened up, the SD was jammed in socket unusually tight (in cple thsnd times I’ve never seen / experienced similar). Finger nails could not remove - trying is what cracked orig SD. Used tiny jewelers pliers with paper jaw pads to finally get out. New SD goes in/out as would normally expect but get the GRR at pwrup now. Willing to do here any testing you might suggest before returning for checkout. Been using Segger with some BLE work and Nordic Dongle but haven’t experimented with its wifi just the BT. It supposedly works 2.4Gh networks and also use the SDK but haven’t wanted to poke your ESP-12S for obvious reasons.

I would get a USB cable and connect the IotaWatt that way. You might need to use a powered hub if your PC doesn’t provide enough power. The IotaWatt prints a lot of information about what it is doing and what is wrong on its serial port. Use a terminal program to see what it is saying. I use TeraTerm, but there are other choices like putty.

I would guess that IotaWatt can’t read your SD card. That is possibly because it is formatted with exFAT. Pretty sure IotaWatt only understands FAT32 (which has a limit of 32GB typically). I have partitioned large drives to have a small first partition to allow FAT32 formatting.

Great suggestions thanks. Partition makes sense, will try (with Covid restrictions is easier than going out for new SD). Probably right on the exFAT. Some familiarity with TeraTerm too, will try. Great way for an old fart to stay busy.

All of the push-pull SD holders are hard to use. I’d guess that 98% of IoTaWatt users have never had to do it. The ESP32 prototype uses a push-push holder. Much nicer, but adds $1 to the cost and it’s rarely used. Wouldn’t be an issue if I manufactured in China, but I’m committed to building here in New Hampshire.

Sounds like @frogmore’s suggestion will work. There is a slight advantage to using a level 10 card, but it has to be FAT32.

Will try to join that 98% quick as can - thanks for the follow up

Pic of new partitioned SD properties (D:) - get same on 2 dif cmptrs.
Pic of SD (D:) files in root (cloned from Github)

Placed SD in iotawatt and pwrd up but get GRR only now (SD reader error I believe)

Original unopened iotawatt on pwr up G pause then repeating RGG as previously indicated.

Device Config menu has never yet appeared even on initial as received (unopened) and accessed:

Used manual procedure “SSID recognizable by the prefix iota followed by a unique number” which was : iota12707449 but no configuration screen appeared.

Per manual tried IoTaWatt.local/command?disconnect=yes
also iota12707449.local/command?disconnect=yes
also 'iota12707449/command?disconnect=yes alsohttp://iotawatt.local` tries to reach 'https//www.iotawatt.local and sometimes disconnects wifi
and various others
Reconfigured network not to require https but still times out https//www.iotawatt.local
Did network diagnostic with disconnect results iota.txt (attached see lines 96-104)
Cant kill the DHCP if can’t connect at all - tried MAC address.

I’m run out of options / time and still conclude bad reader is blocking the ES from fully doing its task.
I don’t pretend to be an expert but I’m way past a beginner computers since 1967 -Osborne, PC, AT etc etc and some Arduino. Also not able to fully access thru USB Tera Term but still looking for right settings to talk. Do get a response but no data.

If you spot anything you think would change things plse advise. Otherwise let me know to send back for inspect / replace.

I identified and solved my initial power problem by brute force so not in a panic but I still want to monitor and log.

iotaDiag.txt (7.2 KB)

OK, just send it back and I’ll take a look.

Some progress. Found my CPAP uses 8G card. Wiped formatted cloned files. Seated and is behaving as original 3secsG then repeats RGG. Shows up on phone, laptop, and an old tablet. I can get to the config but not into configurkng selection. Interestingly the reset selection actually does ota reset!. Will continue to striggle but focus on router settings and leave sd alone. ES looks ok as intermediary server but noable t get though to 2g touter conn. You’re off hook for cpl days st least.

As b4, I want to work with my/your iotawatt

Believe Charter/Spectrum supplied Sagemcom F@st 5260 router interfering/blocking with wifi-Direct. Trying to get info from Charter and Sagemcom is proving interesting, the one speaks little English - the other only French (/en reverts to /fr after 1 or 2 screens)

Research suggests wifi-direct same as P2P (those memories not great either) but wifi direct appears to be a more ‘automated P2P’?

Can you recommend known to you router that works out-of-box smoothly with iotawatt?

Poss would an intermediate booster of more current tech bridge with minimum angst?

Is why I went/want iotawatt - provides me workaround options (if required!) while others wanted subscriptions or pinned me with hard coded interfaces (no thanks).

Wife is 24/7 on-call SAP programmer for TDS - but is network/pc clueless. Router downtime tends to get loud.

I have noted your references to Emoncms, influxDB, PVoutput but I’m focused on using, not configuring (unless really, really necessary - ouch).

Any suggestions / insights (other than new wife)?
Thanks, dp

I think any lawyer will tell you that a new router is cheaper than a new wife. Really, any commodity router linksys, cisco, etc. should work fine. Start off with the basics. Setup the WiFi, connect the IoTaWatt, then connect your computer/tablet/phone to the same router. It should work. After than, you can try changing one thing at a time until you get where you want to be.

Networking is a specialty unto itself in an ever changing landscape of new technology. I can’t represent that I can give you expert advice. On the ground, in your environment with access to google and WiKi, I think I could figure out just about anything, but not remotely. People only tell you what they want you to know.

There’s always my general advice to old-timers: Get a kid. They are fearless and look at technology as if it’s always been that way.

Generally agree on the kid tho I seem to be [more or less] the fearless neighborhood tech they (and their parents) come to, oh well - also pc, carpentry, auto, maintenance, welding, wiring, machining etc. Not sure at this point whether should be thanking or damning my long deceased father.

Also on lawyer / wife : I certainly got the volume with new wife that I paid the lawyer for! After 20 years with ‘new’ I’m not sure which side of the cost / benefit your assertion would come down on going forward tho. Thanks for the thought tho. Going first to try and push Spectrum into new router, suspect this one was obsolete to start with.

I admire what you’ve done with the iotawatt. I’ll try not to bother you further unless actual iota arena. Thanks for your time.

So much for leaving you alone …

Does the iotawatt itself need an internet connection or would an access point work as wlan for now to maybe connect later to existing router. Physically my space is relatively open and cabling ethernet to router later would save lots of angst here.

It doesn’t need internet continuously. If available it will check the time every hour and update any drift in it’s clock - usually < 2 seconds/day. It will also check regularly for firmware updates and auto-update per any auto-update class that you have set.

So you can get away with a few weeks without internet connection. If you see the time in the message log getting too out of synch, consider giving it a peek at the internet.

Thanks for quick response. Spectrum has agreed to exchange router but this input gives me room to experiment before disconnecting SWMBO (she who must be obeyed) even briefly. Really does get 24/7 calls to jump on and troubleshoot TDS’ business software so I try to be considerate. Only gives me a couple more -db relief but helpful.