Struggeling to get InfluxDB to work


Using Home Assistant I have setup an InfluxDB (basically clicked install & run). However after setting up a new db and user I’m unable to get IotaWatt to push data to InfluxDB. It always returns me

I tried debugging this as much as possible, but I’m out of ideas so here’s my config and some of the things I tried.
For simplicity I’m testing with iotawatt as username and password.

Important to note is that the delete button doesn’t do anyting. I assume it’s supposed to clear all settings but it just returns me to the index page.

InfluxDB setup

IP & port are correct

Accessing the query api asks for login:

Logging in with iotawatt/iotawatt works:

The log doesn’t show much info either.

** Restart **

SD initialized.
11/02/21 22:16:51z Real Time Clock is running. Unix time 1635891411 
11/02/21 22:16:51z Reset reason: Software/System restart
11/02/21 22:16:51z Trace:  1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:3, 1:1[6], 1:2[7], 9:0[7], 9:0, 9:1, 8:4, 8:6, 8:8, 8:9, 9:3, 9:5, 9:9, 1:2, 1:3, 10:2, 10:3
11/02/21 22:16:51z ESP8266 ChipID: 14774540
11/02/21 22:16:51z IoTaWatt 5.0, Firmware version 02_06_05
11/02/21 22:16:51z SPIFFS mounted.
11/03/21 00:16:51 Local time zone: +2:00
11/03/21 00:16:51 Using Daylight Saving Time (BST) when in effect.
11/03/21 00:16:51 device name: IotaWatt
11/03/21 00:16:51 HTTP server started
11/03/21 00:16:51 influxDB_v1: Starting, interval:10, url:
11/03/21 00:16:51 timeSync: service started.
11/03/21 00:16:51 statService: started.
11/03/21 00:16:51 dataLog: service started.
11/03/21 00:16:51 dataLog: Last log entry 11/03/21 00:16:45
11/03/21 00:16:55 WiFi connected. SSID=FluxFiber, IP=, channel=6, RSSI -47db
11/03/21 00:16:55 MDNS responder started for hostname IotaWatt
11/03/21 00:16:55 LLMNR responder started for hostname IotaWatt
11/03/21 00:16:55 Updater: service started. Auto-update class is MAJOR
11/03/21 00:16:56 historyLog: service started.
11/03/21 00:16:56 historyLog: Last log entry 11/03/21 00:16:00
11/03/21 00:16:57 Updater: Auto-update is current for class MAJOR.

Feels like an issue with IotaWatt since I can access InfluxDB correcty from the browser. Is there some verbose logging I can enable or another way to debug this?

Change the first tag to

device = iotawatt

There is a problem with using the variable $device as a tag value. The problem is fixed in the next release coming out soon.

Changed it and doesn’t help. I also restarted just in case.

Might have something to do with the third tag-key being $units. It’s a little redundant anyway as your field-key is also $units.

for what it’s worth, here are my influx settings:

You still have $device as a tag value.

Looks like there is indeed a bug with the variables. I changed my config and it started sending data to InfluxDB :partying_face: thnx!