Suddenly Influxdb uploader has a problem

Hi there,
I am not sure about what happened. Suddenly, without any reason I am not getting the measurements on influxdb anymore.
Firmware version: 02_08_02
I checked the status: Query failed, code 400, response: {“error”:"error parsing query: found 110, expcted
Tried to stop and start the influxdb service, reboot the device. No changes, I don’t get data anymore oninfluxdb.
I checked the logs:

SD initialized.
7/28/23 08:26:56z Real Time Clock is running. Unix time 1690532816
7/28/23 08:26:56z Reset reason: Software/System restart
7/28/23 08:26:56z Trace: 1:3, 1:6[1], 1:6[2], 1:6[2], 1:6[2], 1:6[2], 1:6[3], 1:5[19], 1:6[4], 1:6[6], 1:1[4], 1:2[5], 9:0[5], 9:0, 9:1, 8:4, 8:6, 8:8, 9:3, 9:5, 9:9, 1:3, 1:3, 1:6[1], 1:6[2], 1:6[2], 1:6[2], 1:6[3], 1:5[20], 1:6[4], 20:0, 20:1
7/28/23 08:26:56z ESP8266 ID: 15876447, RTC PCF8523 (68)
7/28/23 08:26:56z IoTaWatt 5.0, Firmware version 02_08_02
7/28/23 08:26:56z SPIFFS mounted.
7/28/23 10:26:56 Local time zone: +2:00
7/28/23 10:26:56 device name: IotaWatt
7/28/23 10:26:56 HTTP server started
7/28/23 10:26:56 influxDB_v1: Starting, interval:5, url:
7/28/23 10:26:56 timeSync: service started.
7/28/23 10:26:56 statService: started.
7/28/23 10:26:56 dataLog: service started.
7/28/23 10:26:56 dataLog: Last log entry 07/28/23 10:26:55
7/28/23 10:27:00 WiFi connected. SSID=200, IP=, channel=6, RSSI -58db
7/28/23 10:27:00 Updater: service started. Auto-update class is MINOR
7/28/23 10:27:01 historyLog: service started.
7/28/23 10:27:01 historyLog: Last log entry 07/28/23 10:26:00
7/28/23 10:27:02 Updater: Auto-update is current for class MINOR.

** Restart **

I even tried to post the data to another influxdb on a different machine. But no luck.
It was running perfectly since a couple of months ago and I have not made any change since then.

I would appreciate some help

Please post your influx setup and the status display with the influx message.


110 is not a valid measurement name.

Has been working like that since May. I am not sure what and why now the device considers 110 to be not a valid measurement name.
I have other sensor posting to the same measurement and there is no issue with those.
Actually has never been an issue even for Iotwatt until this morning.
I tried to change the measurement name to abcde and then it works. But then, what’s suddenly changed?

Thanks for supporting.

I question that, but easy enough to verify. Can you show me some entries in your influx database with measurements named “110”?

Here it is: It stopped working this morning. I have no reason to say false things on this forum. I genuinely started experiencing this issue only this morning after months of it working fine…

After the test of changing name of the measurement to abcde which resulted positive (it was posting). I have now put it back on 110. No errors, it is running but influx doesn’t receive the data.

The status display shows it running and loading data from 07/06/2023. I would recommend you restart the IoTaWatt using the Tools->Restart option in the app. Then if you want me to look into this further, please download /iotawatt/iotamsgs.txt and upload to me in a PM.