Using a tablet/phone

Greetings All,

I can not s em to access my IoTaWatt on my Google phone and Samsung tablet. But if I use my Surface Pro, I have no problems. As I don’t want to take a tablet, phone and laptop to work, how can I get the IoTaWatt on my phone or tablet. Screen shot of the message when using my phone. It is the same message on my tablet. I am also using Chrome on all 3 devices.

Hi Darraj,

IoTaWatt is connected to your local LAN. you report that you are able to connect with a browser on the local LAN.

If you want to connect from outside of your local LAN, you will need to configure your router to assign a fixed IP to the IoTaWatt and then configure port forwarding in your router to redirect an unused port number on your router to the local IP/port of the IoTaWatt. You might also want to configure a dynamic DNS service to facilitate locating your router from the internet.

Be aware that doing this exposes the IoTaWatt to malicious access. There is an authorization feature in IoTaWatt, but no encryption for web server transactions.

An alternative is to upload your data to one of the web-services supported by IoTaWatt and use the visualization tools associated with that service from the internet. InfluxDB and Emoncms are two offerings supported by IoTaWatt.

Assuming your phone/tablet is connected to the same WiFi network as your IoTaWatt…try using the IP address of the IoTaWatt instead of “name.local”.

Something like

Overeasy, I am connected to my home WIFI. I only just got the IoTaWatt and was setting it up at home. After it connected to my home WIFI, I then used my tablet to do the set up. No go, then I used my phone, didn’t work, then I used my Surface Pro and no issue. Every time I tried to connect to the IoTaWatt it was using what was written in the manual. But for some reason my phone and tablet won’t Connect to it. But I have just tried using the ip address in the phone and it worked.

Basically I won’t to go to a customers house install the IoTaWatt for a period of time. But I looks like I will need to take my laptop with me as the tablet and phone won’t connect via typing http://IoTaWatt.local

Ogiewon, thank that works, but as the ip address would change when I set it up at a customers house the. That means I would have to use my laptop to set it up as I won’t know what ip address is at the customers house. I am confused as to why on the phone/tablet you can’t just type in the device name /local To connect to it, but using a laptop we have no dramas?? What is the difference between using chrome on a laptop to a tablet?

The whole http://IoTaWatt.local is something I would not depend on, personally.

I have had times when my iPad worked fine using it while my Win10 desktop could not. And I have had that behavior flip flop as well.

If deploying for a customer, I would be sure to create a DHCP Reservation in their router. This way the address will not change. I do this for most of my devices at home.

The .local domain designation is part of a kludge that started with apple’s bonjour print configuration service. The idea was be able to locate printers on a LAN without needing to configure.

The protocol was called mDNS, which stands for multicast domain name service. The way it works is that when your enter a .local URL, your computer broadcasts a multicast message on the LAN for all devices, basically asking “anybody out there calls themselves IoTaWatt?”. IoTaWatt responds to that with a message saying “I do, and my local IP address is x.x.x.xl. So now your browser knows the IP address and can subsequently access directly.

Fast forward a few years from apples’s bonjour, and there was a wider effort to establish a standard for a similar but the same protocol. As I understand it, the effort was called zeroconf. I have not seen where it enjoyed adoption, but Microsoft put out their own called LLMNR.

IoTaWatt listens for multicast packets of both protocols. But lacking a standard, every device is different. So some work and some don’t. Apple devices all seem to work great using the bonjour service. Some Microsoft devices, including windows 10 devices, seem to work with LLMNR. Others just don’t. I could setup a lab with 100’s of computers and mobile devices, a few dozen common routers and systematically try to figure it out, also varying all of the versions of software that they run. Unfortunately I don’t have hundreds of thousands of dollars and unlimited time.

So here are a few suggestions to try to work within the limitations.

  1. Get an apple phone or tablet.
  2. Try using the protocol prefix “http://“ as in “http://IoTaWatt.local
  3. Try restarting your router and the IoTaWatt.
  4. Install bonjour on any non-apple device for which it is available.
1 Like


Thank you for that, that makes sense. I have downloaded a bonjour web browser and discovered the IP address of IoTaWatt. That will help me set it up with out a laptop. Cheers much appreciated for the support.

1 Like