Web files frequently not loading on 1 device

I have 4 IoTaWatts, 3 of them work perfect but one of them has never worked quite right as the UI frequently fails to load. Sometimes it just never comes up, sometimes the main HTML is the only thing that loads, none of the other stuff (cnfstyle.css, tables.txt, config.txt, burden.txt). When the page does load the buttons sometimes don’t do anything (console shows “mainMenuButton is not defined”, etc). I also have a much larger frequency of API failures on this device than the others and this problem device has the fewest CTs being monitored of the 4 I have. I’ve included one example snip of what I see in the UI. This device is also the only one I have that becomes unresponsive, but the signal strength is fine at around -54 every time I am able to get it to load. I have not yet tried replacing the micro-SD card, I’d prefer to not lose the history.


There are not many problems with IoTaWatt these days. What few issues are reported are almost all SDcard or poor WiFi. There was a spate of SDcard failures due to a few hundred defective cards, but none of the units you bought from the stuff shop are subject to that.

I’d look at WiFi first. RSSI signal strength is not the only indicator of WiFi reliability. The unit could be using a different AP on a different channel from the others or there are a lot of devices that use the 2.4GHz frequency, including wireless phones. A poor quality device close to your unit can cause WiFi problems.

If you are certain the WiFi is not a problem, the next step is to replece the SDcard. If you want to try to keep your history, I would recommend copying the /iotawatt/histlog.log file. That will retain your 1 minute history and the history log is much less likely to have damage than the current log.

There’s almost nothing close to it and very few 2.4GHz devices in the houserunning a long ping shows it has better times than the other 3 units and ping still responds even when the web & API are not responding. It is also connecting to the same AP as 2 of the others and the other two are around -68 strength. I’ll try replacing the SD card, knowing I can just copy the histlog.log file is good to know.

Replacing the micro-SD card did seem to do the trick, thanks for the help. Grabbing the contents of config.txt helped for getting it set back up.

1 Like