Why did my IoTaWatt unit stop working (outlet related?)

Background: I stopped seeing energy data on my grafana graphs around 1/5 at 11:44AM EST. I tried navigating to the IP address of the IoTaWatt in my browser and it was unresponsive. Looking at the unit, the LED was dull & unblinking red, not solid green as usual. I tried disconnecting power and reconnecting, several times but the unit would not connect to wifi.

I remembered @overeasy in the past suggested my wifi signal is too weak near the unit, so I disconnected the IoTaWatt and brought it inside the house to see if it connects to wifi there. It did indeed connect right away when I powered it on inside the house, near my wifi router.

I started a project to get an AP in the garage near my IoTaWatt unit. That project finished yesterday and I had run an ethernet wire out there and had an access point set up just a few feet away from the IoTaWatt, but the IoTaWatt still had the same behavior (solid red LED, no connection to wifi). I could not see the IoTaWatt unit in my router in the list of connected clients.

Just for giggles, I plugged in the IoTaWatt unit to a different outlet nearby, and it connected to wifi right away (solid green LED).

Am I understanding correctly that somehow the different outlet is affecting the IoTaWatt unit? If so, how could this be?

Both the 5v power and AC reference power are connected to the same outlet as each other, both before and now (but now they are on a separate outlet than the original).

I’m concerned, I don’t understand what caused the issue and how to address it if it happens again.


message log please.

20240111_IoTaWatt_Log.txt (9.7 KB)

It would appear from the message log that the unit is running OK now, connected to WiFi, and posting to influxDB. You had an outage where the unit was not functioning from about 1/5/24 03:29:20 to 1/7 11:27:32 when the unit was restarted after a power failure. Since then it appears to be working fine.

This was not a controlled experiment (just for giggles) and there is no evidence that it was ever reproduced or that reproduction was ever attempted. Exactly what do you expect me to do here?

Sorry if I was unclear. The short answer is I’m trying to get an understanding of why the unit wasn’t working before. Your summary of the events sounds like it’s based exclusively on the log, not sure if you understood my original post. I’ll summarize the events another way:

  • 1/5 11:45AM - IoTaWatt stops reporting data, shows a solid red LED. I unplugged and replugged back in the device several times without success.

  • 1/7 11:35AM: I have an idea to bring the device inside the office (where the signal is stronger) to test if it will connect to wifi, without any CTs connected to it obviously. It does indeed connect to the wifi successfully. From these events it seems maybe the wifi signal is not strong enough in the garage, so I started my project to install a new wifi AP in the garage. The IoTaWatt remains plugged in, inside the house until -

  • 1/10 9:45PM: I finish installing the new Access Point in the garage. I move the IoTaWatt back to the garage and plug it in but it still doesn’t connect to wifi and still has a solid red LED. I unplug it and plug it back in several times but it never connects.

  • 1/10 10PM: Out of other ideas, I then try moving the power cords to another outlet and to my surprise it connects to wifi within seconds, and displays a solid green LED.

Grafana screenshot for reference:

(notice that the last set of actual meaningful data was on 1/5, and no more meaningful data until late on 1/10 (when I moved it to the alternative outlet).

Yes, thankfully the unit is currently working.

This doesn’t quite describe what I observed. The successful connection to wifi on 1/7 was inside my house, not near the original location where the CTs are. Even last night on 1/10 it still wasn’t working in the original location until I moved the power plugs to a different outlet. There was no power failure at any point in time. The original outlet appears to be functional and has power, I don’t think outlets generally have elements of quality associated with them - they usually either work or they don’t.

I may have been using wrong terminology here. To be clear: I was never giggling, I was extremely frustrated because there were no environmental changes on 1/5 when the unit stopped working. It was seemingly random. I was especially frustrated last night when I installed the new AP and it still wasn’t working. There absolutely were attempts to reproduce the issue, because I unplugged the unit and plugged it back in many times across several days, and it did not resolve the issue. I dont know if you have any other ideas on how to reproduce it - aside from plugging it back into the original outlet where it stopped working on 1/5.

This post is a request for ideas on why the outage happened, because I still don’t know why.

Based on the power cycling that I’ve tried since the original issue on 1/5, I would expect if I moved the unit back to the original outlet, that it would again have trouble connecting successfully - and I don’t know why.

As a side note - I hope I’m misunderstanding the tone here because just from reading it sounds a bit hostile. Thanks

It is very difficult for us to even hazard a guess as to why you’ve seen what you’ve seen. If you were to move both power supplies back to the original outlet, and record results. Then move back to the ‘new’ outlet, record results. and repeat that process about 10 times… then we’d have some experimental data to use to formulate a hypothesis as to what might be going on.

Having photographs of the installation would be helpful as well, in both configurations, as well as showing the relative position of the new Access Point to the IoTaWatt device. Also, is the new Access Point using 2.4GHz WiFi, or only 5GHz. The IoTaWatt requires 2.4GHz WiFi. I would suggest using channels 1, 6, or 11 for 2.4GHz WiFi with a 20MHz channel width. This is the most compatible 2.4GHz WiFi setting that I have experienced for most devices.

Without additional data, you’re asking us to simply take a stab in the dark to explain what you’ve presented to us thus far.

I can’t tell you what happened there. I can say that from the log, or rather absence of log activity and log restart time on 1/7, the unit was not working at all. There is no LED error code solid red. If it were dull red, that would mean monitoring but disconnected, however it was clearly not monitoring and no disconnect was logged. So it’s a one time-failure that has not recured. Could be a number of things, but I’d suspect your USB power supply first.

You want me to speculate on something that you suspect would happen?

It’s not hostile, it’s dismissive. What was your original order number? If the unit is less than a year old, you can send it back, with the power supply, and I’ll look at it. If it’s more than a year, I’ll do the same but will charge time, materials and postage.

Thanks for the polite response and suggestions, @ogiewon, and thanks for the request for specific data. As you requested, here is a photo of my configuration - please excuse the mess. I would like to say that before the recent events since 1/5 that it was originally less messy, but that would be fibbing

The new AP is circled in blue, it’s a TP Link EAP 245 V3. To answer your question, it supports both 2.4 GHz and 5GHz. I have it running in dual SSID mode so it is advertising wifi on both frequencies. The outlet circled in green is where the IoTaWatt was originally plugged into prior to 1/5. As you can see, everything is literally within a few feet of each other. If it helps/makes a difference, the outlet circled in green is actually on a separate electrical circuit from the outlet that the IoTaWatt is currently plugged into.

As I mentioned earlier, the IoTaWatt is currently connected to the network, so the proximity and frequency of the AP is controlled in both scenarios: when it was not connecting and now that it is connected. In my AP app, it shows the IoTaWatt as having a strong signal currently:

I confirmed that I am currently using channel 11 for the 2.4 GHz band.

I may try your suggestion to swap back and forth between outlets 10x later on, for now I was happy to be logging data again after almost a week.

Thanks, this info is helpful. At one point early on I was wondering if the power supply was failing/had failed too, but since the unit was successfully connecting inside the house on 1/7, I ruled out the power supply as the cause of the issue.

No, I was hoping you would speculate based on the things I mentioned I already did and their results. For example, I don’t think the power supply is an issue since it did connect immediately in two scenarios: in the house, and when plugged into the alternative outlet. I don’t think the IoTaWatt is faulty per se, because in the same two scenarios described in the last sentence, it booted up and connected successfully very quickly. The only common factor in all scenarios in which it didnt work, was that it was plugged into the outlet circled in green in my picture. Hence my suspicion that somehow that outlet in particular is affecting the IoTaWatt operation.

Thanks, I appreciate the offer for technical support. If the unit fails again in the future I may take you up on that route. For now, since it’s working I prefer just to leave it as is (otherwise I miss out on the data). I have had this unit for about 5 years now, I have no idea whether there are any statistics on how long they usually last, and if I should expect to replace it or request for service/material support anytime in the near future.

I appreciate your candor. I apologize if my original post did not have sufficient information to be useful to you. Believe it or not, I am actually in a technical support position in my day job and so I appreciate the scenario when someone tells me that one of my team’s systems is “not working” without much more info. However, I may internally roll my eyes when that happens but then I proceed to ask questions to get the info I need to troubleshoot.

My only hypothesis, from looking at the picture, is that the wires from the two power supplies are directly between the IoTaWatt and the AP when plugged into the original outlet. Perhaps this was enough to attenuate the signal, or interfere with it?

From what I’ve seen, every time the unit started, it connected. Failing to connect is not the problem. From what you describe, your problem appears to be that the unit does not power up properly and does not monitor at all, or do anything else like log messages, monitor power or connect to the internet.

Now that you have told me that your unit is 5 years old, I would move bad SDcard to the top of the list.

1 Like

Thanks for this response. Recall that last week (before the issues began), that AP wasn’t there. There was only the IoTaWatt in this area, so there shouldn’t have been interference/signal overlapping, etc (as I understand it).

Thanks. What is the recommended way to address this proactively? I remember reading in other posts that you have mentioned the SDCard is quite delicate/fragile. Is replacing the SDCard something I can/should do as an end user?