Always dull red light

Hi,

It’s been 4 years with the IotaWatt. Had to change SD card twice cause it got unreadable. This last time, when i changed the SD card i did the same as ususal. Copied the SD fies from github.

Didn’t enter the AP mode it’s just showing the red dull led.

Reading the forum I created the iotalog and iotawatt folders with the .log files, also I changed the config file from “MINOR” to “NONE”…

Any change, it just keeps with the red dull led…

Any idea on how get it working?

Thanks.

Hi @GerardT,

Dull red light can be a few different things. Lets try to narrow it down.

Why are you expecting AP mode? Has your WiFi SSID/passkey changed? Did you disconnect it? Did you flash it?

Given one of the above, it will only enter AP mode after a power-on restart. Simply pressing the reset button on the PCB will not do it.

There are two reasons why the light would be dull red during normal (sampling) operation. The most common is WiFi not connected, but the other is that the IoTaWatt doesn’t know what time it is, so can’t log data. If it’s connected to WiFi, the unit should eventually go to green if it can access a time server, also you should be able to access it via iotawatt.local with your browser.

Another failure mode involves problems with the ESP8266 booting from flash. This is very rare, and is usually associated with a failed attempt to flash the device. Have you by any chance tried to do that?

If you have a micro-USB cable and a computer, you can run connect it with that cable and run a serial terminal like Putty (115200 Baud). If it doesn’t print anything when you reset it, then the ESP8266 is either toast or needs a reflash. If it does output anything, I can take a look and probably figure out what’s going on.

We changed the pasword and the wifi SSID. I tried to get a message through Putty… nothing, just black screen. I never tried to reflash the device… but it looks i’ll have to do it now. Any post on how to do it?

Thank you.

Not so fast on the reflash. Not indicated yet. So what happened was that it was working OK and you changed the SSID and WiFi password? Then restarted the unit and it was just dull red?

Can you remove the SDcard and upload /IoTaWatt/iotamsgs.txt? Probably better to upload it to a private message read.

It was working until it stopped posting. After a restart green-red-red sequence started. We checked the SD card and was impossible to read.
After buying a brand new SD card and copying the Github files. The led was just dull red and didn’t connect to the wifi neither enter the AP mode.

Took it home to try to fix it, so now there’s a different Wifi configuration.

It’s true though, that if i take out the SD card the red-green-green sequence starts.

Sorry, there’s no /IoTaWatt/iotamsgs.txt file. Tt have not been created. Not iotalog.log neither.

You describe both a GRR and RGG pattern. Those are very different. Are you sure you get RGG with the SDcard removed?

It never did the RGG. Always GRR if there’s no card or its unreadable. The rest of the time just dull red led.

OK, thought so. You probably know from the troubleshooting docs that GRR is an SDcard problem. Given that you report the unit gives that code without the SDcard, but is solid red with, my first choice is the SDcard itself. It could also be a problem with the SDcard holder, but it’s a pretty simple thing and if it’s been working for four years, I’d fully explore the SDcard itself.

You were unable to access the card from another computer after the initial failure. Are you sure the replacement card is a FAT32 format? If you are in the USA, I can send you a tried and tested card.

BTW/ Since yo get GRR w/o the card, the device does not need flashing.

Something happened, it entered the AP mode with the RGG patern… i ll try to explain.

With a new SSID

  1. With the SD card inserted, if I power restard i gets stucked in the dull red led state. Can’t connect using any wifi.

  2. If, once its powered on I take the card out and put it back, it doesn’t change and stays on the red dull led state. Can’t connect using any wifi.

1.If I power it without SD card, it starts the GRR patern, but if i insert the SD card while in this state, it changes to RGG patern and changes to AP mode. I can connect to the iota AP.

So, it’s kind of solved… but theres something not right…

P.D.: Its a brand new SD card well formatted to FAT32.

I realize this has worked for you, but for anyone reading this, it’s never a good idea to remove or insert the SDcard while the unit is powered up.

@GerardT, now that you have WiFi configured, what happens if you power cycle or press the reset button inside?

You’re right. That’s why i never tried to connect the sd card while powered on…
If I reset somehow, power or pressing the button, it gets frozen on the dull red led state.

SOLVED. Following this thread …

Interesting. Are you saying that you added a resistor to your board and now it boots OK with the SDcard?

Every IoTaWatt ever manufactured has an ESP12S, so maybe there’s more to it than that, but I do have a couple of units that previously failed manufacturing diagnostics with similar symptoms. I’ll take a look. Adding a pullup is easy.

Thanks

Yes, it works better than ever actually. We always had some problems accessing using http… it got slow, or loosed connectivity. We also burned 2 SD cards in 4 years… I guess everything its related.

So yes, after welding a 10k resistor between GND and D8. Works perfectly.

You are welcome.

If you still have access, I would like to see a picture of your PCB. Given the age of the unit, it could be one of the earlier prototypes and may not have had the ESP12S. I just measured an ESP12S on it’s devkit3 and there is 6K resistance between GND and D8. That’s a pretty strong pulldown. Adding a 10K would make it stronger. So I’d like to see if maybe this could be particular to an older prototype unit, of which there were I think 50 sold.

I don’t see that being a viable alteration on the later units.

I don’t have access so far, but I’ll try to do it for you… I think we bought it quite early because we were… just checked, we bought it on December of 2017.

I’ll send the picture after tomorrow probably.

I upload the pictures you asked. Just to inform you, so far is working without any problem and reacting perfectly to any kind of reset.

Thanks,

That’s the first pilot run. Doesn’t have the ESP12S. I couldn’t find any of those particular nodeMCUs in my spares box, but did have some other non-esp12S units. They measure 12K between D8 and GND. So adding 10K will take it down to about 5.5K. The ESP12S nodeMCUs in later model IoTaWatt have 6K there. So while this improves your unit, I would recommend against using on an ESP12S unit as it would drive the resistance down to 3.75K and would put about 1mA load on D8 to pull up.