Blinking Green LED, restoring SD card does not work

I have had my Iottawatt installed and working since August 2022 (Order #127107). Two weeks ago it stopped reporting, and the web interface was unreachable. I have not changed the configuration in months, and the last time it had been power cycled was also likely months ago as well during a power outage.

It has been blinking green, about once a second. My router claims that is it connected on it’s static IP; but the device does not respond on HTTP or pings. I also have tried manually power cycling it; no change.

I have found this other post that seems to be the same problem. I followed the advice posted there to restore the files on the SD card; tried both on the original SD card as well as a new SD card formatted to fat32. This still causes the same flashing green rapid-reset.

Both before, and after the sd-card resets these are the messages in the iotamsgs.txt file.
iotamsgs.txt (22.7 KB)

SD initialized.
10/20/23 18:22:13z Real Time Clock is running. Unix time 1697826133 
10/20/23 18:22:13z Reset reason: Exception
10/20/23 18:22:13z Trace:  0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 0:0, 11:0, 11:4, 11:5, 11:5, 11:10, 11:15, 11:20, 11:20[1], 11:20[2], 11:20[3], 11:21, 11:22, 11:20[4], 11:20[5], 11:20[6], 11:20[7], 11:25
10/20/23 18:22:13z ESP8266 ID: 15885208, RTC PCF8523 (68)
10/20/23 18:22:13z IoTaWatt 5.0, Firmware version 02_08_02
10/20/23 18:22:13z SPIFFS mounted.

It’s having a problem configuring an integrator. Power the unit down and mount the SDcard in another computer. Post the SDcard directory, the iotawatt/ directory and your config.txt file please. Use a PM if there is sensitive info in your config.

Thanks for the quick reply. I do not believe the problem is with my config; it also does not work with the default “empty” config. That is what I meant by reset; I had already deleted the SD card and re-populated it with the base files you referenced in the other post I linked.

But here is the config I was using for the last year or so:
iottawatt_config.txt (4.3 KB)

With that config, or the default base config I get the same message in the log file as what I posted and the blinking green LED. Unfortunately I do not have the contents of the old iotawatt/ folder; I only backed up my config before wiping the SD card.

You may be right, but I can only follow where the trace and code takes me. Good luck.