Can't get past initial wifi setup

I’m attempting to install a new IotaWatt monitor and can’t get past the initial WiFi setup.

I can connect to its IotaWatt#### network and input the SSID and PW for a 2.4 GHz TP-Link mesh network (it has both 2.4 GHz and 5 GHz networks). IotaWatt seems to properly connect to the 2.4 GHz network and I can see it in the router list of DHCP distributed addresses.

When I connect to that IP address the response is very slow (a couple of minutes) and I get a somewhat garbled list of the initial menu items…

Screenshot 2022-05-18 164723

It seems as if there is a very slow and lossy link between the browser and IotaWatt, both on the same network of course.

Thanks for any pointers about how to proceed.


It appears to be connected. led should be green.

Sounds like a poor wifi connection. Can you enter the following URL in your browser and post the response?


You can substitute the IP address for iotawatt.local if need be.

Seems to work OK, properly identifying the SSID, etc. Worked with both iotawatt.local and the IP address, but seems much slower with iotawatt.local in the address.

status.json (123 Bytes)

I can also get a full, working initial menu. I changed timezone/DST setting and rebooted. Menus come back (seemingly fastest with IP, but also with iotawatt.local in address).

I believe getting a fixed IP would likely help - is there somewhere a static ip can be assigned? Or do I have to tie the MAC address to a DHCP reservation?

And thanks for the quick response!

RSSI looks OK. Still think it’s a WiFi issue.

Setting static IP from the device is old fashioned. Typically, you do that in the router, but I doubt that has anything to do with it when you are using the current IP anyway.

Can you display the message log with the app? If not, can you use the following URL


Also, can you turn on the browser debugger (F12) and select “network”, then refresh your app and post the screen?


Message log and image of the network trace during a refresh are below. The screen grab includes the malformed menus I get about 3/4 of the time. Minutes of time taken for the network activity seem to suggest a network config issue. Occasionally things do seem to work and I see a good, well formed menu and can even select items. More often than not selecting them seems to just hang, but occasionally things do appear to work as expected.

My network config is a Verizon router for the internet connection with a TP-Link mesh configured as an AP, and two separate Netgear routers, also configured as APs. I have maybe intermediate networking skills, but can’t swear that there are no strange routing loops or something else in the system. Multiple IP cameras and desktops. laptops, ipads. linux boxes, phones, etc. navigate the network infrastructure OK, though.

I think I’ll try setting things up in an isolated network with a spare wifi router and standalone laptop. That should help me see what to expect from the IotaWatt device and I can go on from there.

Thanks again.

messagelog.txt (9.8 KB)

I’ll stand by to see the result of your isolated network experiment.

Using a different usb power source appears to have resolved my issues. I was using a convenient power brick already plugged in - when I replaced it with the IotaWatt micro-usb adapter things seem to be entirely on track.

Thanks overeasy, your help was much appreciated and had me methodically checking each piece of the arrangement.

This is the same issue I’m facing, however I’m using the OOTB usb power supply that was supplied, I’ll try another power supply and see if that helps.

Here is my breakdown
initial wifi setup is fine to get to and the main menu was working fine for a little while.
Then it just goes into some unresponsive I’m only going to load ever 20 or so times

getting things like curl: (7) Failed to connect to port 80 after 18668 ms: No route to host

I had it working for another 2-5 minutes again and managed to setup another input, then it went back to doing as it was and not loading at all, I was trying to load a graph2 to see the input.

I’ll try a different power supply later today when I can go hunting in the garage.

My wifi access point is super close (unifi AP) like just under two meters away and is a on a IOT ssid so all the advanced features turned off. Unifi says its connected fine as the uptime 9H+

The IoTaWatt should be using the same SSID as your browser device.

Can you post the message log please.

Not familiar with OOTB USB supply. Can you supply a make and model number?

Sorry its the micro usb power supply provided when I ordered it, I ordered a little while ago but have only gotten round to putting in now as I needed to run a new double plug for it near the switchboard, tried from same network on my laptop and it seems to be working…spoke too soon,
though I have also switched power supplies to see if that helps also a 5v 1A but nope still doing the same.

Got the output from http://iotawatt.local/iotawatt/iotamsgs.txt?textpos=-10000

** Restart **

SD initialized.
6/25/22 20:20:56z Real Time Clock is running. Unix time 1656188456 
6/25/22 20:20:56z Reset reason: Software/System restart
6/25/22 20:20:56z Trace:  11:5, 11:10, 11:15, 11:20, 11:20[1], 11:20[2], 11:20[3], 11:21, 11:22, 11:21, 11:22, 11:20[4], 11:20[5], 11:20[6], 11:20[7], 11:25, 11:30, 11:30[1], 11:30[2], 11:31, 11:31[1], 11:31[2], 11:31[3], 11:30[3], 11:35, 11:36, 11:35, 11:40, 11:45, 11:50, 11:55, 11:70
6/25/22 20:20:56z ESP8266 ID: 522385, RTC M41T81 (68)
6/25/22 20:20:56z IoTaWatt 5.0, Firmware version 02_07_05
6/25/22 20:20:56z SPIFFS mounted.
6/25/22 21:20:56z Local time zone: +0:00, using DST/BST when in effect.
6/25/22 21:20:56z device name: IotaWatt
6/25/22 21:20:56z HTTP server started
6/25/22 21:20:56z timeSync: service started.
6/25/22 21:20:56z statService: started.
6/25/22 21:20:56z dataLog: service started.
6/25/22 21:20:56z dataLog: Last log entry 06/25/22 21:18:25
6/25/22 21:20:57z historyLog: service started.
6/25/22 21:20:57z historyLog: Last log entry 06/25/22 21:18:00
6/25/22 21:26:11z WiFi connected. SSID=161 Racecourse Road, IP=, channel=6, RSSI -61db
6/25/22 21:26:11z MDNS responder started for hostname IotaWatt
6/25/22 21:26:11z LLMNR responder started for hostname IotaWatt
6/25/22 21:26:11z Updater: service started. Auto-update class is MINOR

** Restart **

SD initialized.
6/25/22 20:34:26z Real Time Clock is running. Unix time 1656189266 
6/25/22 20:34:26z Reset Reason: Power-fail restart.
6/25/22 20:34:26z ESP8266 ID: 522385, RTC M41T81 (68)
6/25/22 20:34:26z IoTaWatt 5.0, Firmware version 02_07_05
6/25/22 20:34:26z SPIFFS mounted.
6/25/22 21:34:26z Local time zone: +0:00, using DST/BST when in effect.
6/25/22 21:34:26z device name: IotaWatt
6/25/22 21:34:29z Connecting with WiFiManager.
6/25/22 21:36:40z Did not connect after power-fail. Restarting to reset WiFi.

** Restart **

SD initialized.
6/25/22 20:36:42z Real Time Clock is running. Unix time 1656189402 
6/25/22 20:36:42z Reset reason: Software/System restart
6/25/22 20:36:42z Trace:  11:5, 11:10, 11:15, 11:20, 11:20[1], 11:20[2], 11:20[3], 11:21, 11:22, 11:21, 11:22, 11:20[4], 11:20[5], 11:20[6], 11:20[7], 11:25, 11:30, 11:30[1], 11:30[2], 11:31, 11:31[1], 11:31[2], 11:31[3], 11:30[3], 11:35, 11:36, 11:35, 11:40, 11:45, 11:50, 11:55, 11:70
6/25/22 20:36:42z ESP8266 ID: 522385, RTC M41T81 (68)
6/25/22 20:36:42z IoTaWatt 5.0, Firmware version 02_07_05
6/25/22 20:36:42z SPIFFS mounted.
6/25/22 21:36:42z Local time zone: +0:00, using DST/BST when in effect.

@overeasy I think I might see whats happened

I just did an update on my AP (and I also tried tethering to my phone) and the channel has now changed from 6 to 11 on the AP and IOTAWatt seems to be staying responsive. Will give it 24 hours and see. Hopefully the firmware update on the AP solved the issue.

So far its looking good…
[edit] spoke too soon, it died on me again not long later.

aaand its back again… starting to think it is network related but its still very odd, can reach via IP address now but not iotawatt.local, though I do have a custom bind DNS server running too. It became unreachable again while typing this. Will try with a new SSID with only 2.4ghz and see if that changes anything.

turns out the SSID is 2.4ghz only anyway.

That’s been my feeling all along.

.The .local domain, depending on your browser, uses some type of zeroconfig protocol. IoTaWatt supports mDNS (Multicast Domain Name System) which originated with Apple as Bonjour. Also supported is LLMNR (Link-Local Multicast Name Resolution) which is Microsoft’s version. Heaven forbid they get together.

They both work in essentially the same way. Your browser sends a “multicast” datagram to all hosts on the LAN asking “Anything out there that calls itself IoTaWatt?”. IoTaWatt listens fro such messages and will respond to the requestor with its IP address. The requestor then saves that IP and uses it to subsequently communicate with IoTaWatt.

A lot of people make a living navigating the myriad of available routers along with their unique features and settings. The zeroconf protocols are frequently inhibited in public facing networks, and many modern routers have features to limit or restrict their use. I would be lying if I said I understand how they all work.

Safie to say that if you can access via IP but not .local, it’s a problem with zeroconf support.

Hey Mate

A couple of things

  1. What are you using for your router/firewall between your segments ?
  2. That IP Subnet that is listed for the SSID is a strange looking one - is that definitely what you are giving out - as it looks like the one that is given when a DHCP server can not be found ?
  3. As @overeasy has said this seems to be an issue with the myriad implementation of ZeroConf - or MDNS, LLMNR etc etc - as you have multiple subnets/SSIDs are you sure you have a forwarder setup on each segment for this traffic ?

Personally i only use IP or hard coded DNS and DHCP to get to the IOTAWATT


@overeasy I’m starting to think its a weird signal issue, as I’ve got it plugged into my laptop downstairs within about a meter of my other AP and the signal quality, “experience” and connection is behaving, I’m thinking the electrical interference from all my 240V wires is causing a problem and possibly orientation of the iotawatt. I’m going to try moving it onto the wall beside my box (its all internal/inside the house) and see if that changes things.

Update: wifi experience is now fine and it seems to stay up longer but still drops off (even though its connected to the wifi) I’m only accessing it via the ip address now which is a proper ip address, ignore the logs above with the random IP.

@craigcurtin nothing between my segments both my SSIDs are on the same network at the moment.

ignoring zeroconf which I’m no longer dealing with, I’m tempted to solder my other 8266mod to the board and see if it too has the same issue, I’ve already flashed it with iotawatt firmware

I’ve moved the IOTAWatt away from the switchboard and it seems to have helped a little bit, stays up longer, however its bizarre since the AP is in full view and about a meter and a half away. Its as if the esp8266 is loosing its own IP address.

sitting around -52 dBm

if I turn it off and back on again it comes back too.

Hi all,

I’m pretty sure I’ve tracked it down to my unifi U6-Lite AP being dumb/stupid. I’ve got the IOTAWatt connected to my downstairs at -90dbm and it responds fine, so will hunt around and see if I can fix it or talk to unifi guys as to why my U6-LR downstairs works but the U6-Lite isn’t.

New update:

I can only access the IotaWatt from the same Access point its connected to, its the only device that is doing this, it has a fixed IP as well.

Isnt there a default option that is set on the Unifi (assume you are using the Dream Pro ?) to not allow inter vlan connections by default ?


In fact no - by default they should allow routing between all VLAN segments by default - have you possibly added a rule you have forgotten about to disable this ?