Green-Red-Red-Green LED Sequence

Hi All,

I have a new iotawatt, I am in Australia and my unit arrived on the 3rd of this month.
I bought the AUS-Bundle with 3x100A CT’s and I also purchased 10x50A CTs as well.
I am also using the MP3027 reference 9VAC power supply.
I have had all of the CT’s installed and everything seemed to be running smoothly.
I have been doing some reading lately and creating outputs to log things I am interested in such as imported and exported power as well as logging what my 2 solar systems are doing.

Over the 2 or 3 nights I have had to power cycle my iotawatt as when I have gone to check its status webpage I have seen the following in my browser window (either using chrome on my PC or safari on my iphone)

   Not found: GET, URI: /

When this happens and the unit comes up I have noticed a gap in the data when graphed (ie a straight line for a period of time)

For the last 2 nights a power-cycle has fixed the issue and it seemed to run for a day before it happened again.
Tonight when it happened, I went to switch it off and back on again and I am now seeing a green-red-red-green led sequence and am wondering what to do from here.

I can ping my iotawatt device on my home network using its IP address and I get a reply, but all I get is the not fonnd message in my browser window.
I took some screenshots today of both the error and of the unit when it was operating

Regards, Mark


That LED sequence indicates that the config file is corrupted. Not a very common problem these days as the file is checked before it is installed. Coupled with the preceding not found messages, it looks like an SDcard problem.

The first step is to replace the SDcard. Since you appear to be in Australia, it would be better if you can get an 8GB microSD card locally. If so, I can work through setting up and installing it. If not, I can send you one. Your call.

Thanks any recommendations on size and speed/class for the card?
I might have one I can use from my camera gear otherwise I can pop down to the local office works grab one.

Instructions on how to set things up would be great.
I take it to get to and replace the card I will need to take the cover off the unit?

Thanks, Mark

A microSD 8GB or larger up to 32GB, formatted Fat32 (most are).I use speed class 10 but class 4 is fine.

I’ll post instructions later tonight for building and installing the card as there is another user with a similar problem. You will need to open it up.


I have 2 8GB class 10 cards which were spares from my camera that I can use to get going.
Ill keep an eye out for further instructions.

Cheers, Mark

It’ll be a couple of hours.

I’ve posted a couple of instructions in the resources category.

Update. Just noticed that the pics above are full size SDcards. IoTaWatt uses microSD.

Thanks, I noticed that when I read through the instructions.
I’ll buy a new one tomorrow and run through the steps.

In the meantime I did pop the card out of my iotawatt and put it in my laptop to compare it contents with the files from the github SD directory.
Interestingly I couldn’t find anything that looked like it was corrupt when I compared using beyond compare.
Even the config.txt file looked good and complete.
I did use windows to scan the card for errors and it didn’t detect anything was wrong.
When I put the card back in the unit and powered it on it came up ok and seems to be running again, that was nearly 6 hours ago now.

Regards, Mark

Replacing the SD card was the first and easiest diagnostic step. There is another possibility that the SD card holder is intermittent. And another possibility that the card was just not seated in the holder. Best to wait now and see what happens.

1 Like

Just a follow up, since I removed the sd card checked it on my laptop and re-inserted it into my iotawatt its been running without any issue.
Up to over 4 days and 5 hours now of runtime :slight_smile:

I also have a new micro sd card to try in the event that it happens again.
I bought one of these (Sandisk 32GB)

A unrelated question from my setup, My house has 3 phase power and I have 2 separate single phase solar systems.
One feeds in on the 1st phase and the other on the 2nd phase.
During the day when the sun is out it causes the readings to show negative (which isn’t the problem)
Its currently night here (11pm) and my Main_2 input sometimes shows slightly negative such as in the screenshot below.
Just wondering what is likely to cause this?
Could it be interference from nearby cables or other CT clamps?
Or is it not something to worry about?

Thanks, Mark

It’s possible to have negative on one phase when you have three-wire loads (delta). It looks like your AC is three-wire although it does not show negative on any phase. I am puzzled by your water heater using 3,407 Watts. I don’t see where that could be coming from. Is it connected upstream of the mains?

Thanks for your reply.

Regarding the water heater, its on what my energy provider calls ‘controlled load’ or ‘off peak’ and runs at a cheaper tariff in the middle of the night, because of this it has its own separate meter and I think the first phase is split and goes to the hot water as well as my general house power.

I think all my CT clamps were installed after the meter, so my total power is main1+2+3+hot water


Hi Bob,

Sorry to bump up and old thread, however my iotawatt is showing the same problems that I originally reported in March.
Back then after my initial install it ran fine for a few days and then in my browser I got
“Not found: GET, URI: /”
Also at the time I power cycled the unit and got the green-red-red-green sequence.
Back in March I put the SD card in my laptop, didn’t change anything and then put it back my iotawatt and it has run flawlessly until yesterday.
I probably check it every other day, and I also have an uploader sending my solar data to pvoutput.

Back in march I also went out and purchased a new SanDisk Ultra 32GB SDHC card which I kept just as a backup (it was new in its original packaging until I used it this morning)

Fast forward to last night and I noticed I couldn’t access my iotawatt.
Looking at the device it appeared ok, the led was flickering green however by this point it hadn’t uploaded any data to pvoutput for probably about 10 or so hours.
I power cycled it and it came back with the green-red-red-green sequence, so I turned it off overnight.
This morning I replaced the SD card with the new one I had and tried to reuse my config.txt file.
I have attached the config.txt to this message just in case there are any issues with it
After replacing the SD card, I am still seeing the green-red-red-green sequence.

One thing I did note, I disconnected all the cables and brought the unit to my desk to replace the card so all the inputs and reference power supply are disconnected.
On my desk, I reconnected the USB power the unit appears to come up ok, led flickers green and I can access the webpage in my browser and see lots of 0’s
I then connected the ref power supply and this appears to upset the unit, the led changes to red-red-red and I can no longer access the webpage (still no other cables connected at this point).

Any troubleshooting advice would be helpfull :slight_smile:

Thanks, Mark

config.txt (3.7 KB)
iotamsgs.txt (55.2 KB)

That config is definitely scrambled, but you were able to boot the system on the bench. That doesn’t add up for me. How did you get that config.txt?

Can you restart on the bench again without the VT and capture a copy of the config there?

Also, can you mount the SDcard in your computer and delete the following files?


That will delete all of your history. When the unit runs without a VT, it doesn’t log to the datalog. When you connect the VT, it begins trying to log to the datalog and may be running into prior damage, given your history. There was some kind of time server issue on March 21. Nothing messes up a time series database like changing the time by more than a few seconds repeatedly.

The attached config.txt and iotamsgs.txt were from the SD card that came with the unit and has been running with for the last 4 months.
I opened the unit removed the original card and copied its contents to my PC.

I then grabbed the SD card files from the github repository and copied them onto my brand new SD card.
I also thought the config.txt from the original card looked good to me, so I copied it over the github version and put the new card into the iotawatt.

Ill create a new card with just the contents from the github repository, power it up on my desk with nothing attached and see what happens.
I’ll then plug in the ref power, observe and send through the logs/config

Thanks, Mark

Just a further update… I took the new SD card I have out of the iotawatt and formatted it.
I then copied just the files from github onto the new card and put it back in the iotawatt and powered it up.
It booted ok and I could access it from my web browser (chrome)
I plugged the ref power back in with the unit on my desk and all was ok (no red leds or anything)
I let it run for about 10 minutes to be sure :slight_smile:

After that I re-added some of my inputs (phase1/2/3 for my house and my 2 solar systems) and also setup up pvoutput to upload again.

At this point I power cycled it from the web bowser just to make sure everything was ok and I grabbed the config.txt and iotamsgs.txt using the web interface (Tools → File Manager and Editor)
File are
config.txt (1.8 KB)
iotamsgs.txt (2.7 KB)

At the moment I have moved it back to my garage and plugged 5 of my 14 inputs back in.
I’ll continue to keep an eye on it and look at add my other inputs back as well.

I still have the original SD card which the unit crashed with yesterday and I have a copy of its contents if they are of any help.
I am also happy to put the original card back in the unit if you want to try and get to the bottom of why it scrambled its config.

Yesterday when the unit did stop I can see that my last PV output upload was June 6th at 9:55am local time
06/06/22 9:55AM 2.340kWh 0.500kWh/kW 1,781W 1,776W 0.379kW/kW - - 0.000kWh -

The tail of the log from the failed card has the following which doesn’t appear to by until later in the day. is “12:49:54z” close to 1pm local time? (Im not sure of the significance of the ‘z’)

Also I don’t think we had a power outage around that time, I was at work although my wife was home and didn’t notice anything.

5/27/22 07:23:52 PVoutput: System New_Build, interval 5, freeload mode
5/27/22 07:23:53 PVoutput: Start status beginning 05/27/22 07:20:00

** Restart **

SD initialized.
6/06/22 12:49:54z Real Time Clock is running. Unix time 1654519794
6/06/22 12:49:54z Reset Reason: Power-fail restart.
6/06/22 12:49:54z ESP8266 ID: 440304, RTC M41T81 (68)
6/06/22 12:49:54z IoTaWatt 5.0, Firmware version 02_07_05

** Restart **

SD initialized.
6/06/22 12:50:44z Real Time Clock is running. Unix time 1654519844
6/06/22 12:50:44z Reset Reason: Power-fail restart.
6/06/22 12:50:44z ESP8266 ID: 440304, RTC M41T81 (68)
6/06/22 12:50:44z IoTaWatt 5.0, Firmware version 02_07_05

** Restart **

SD initialized.

Regards, Mark

Let’s let that run for awhile. The scrambled config from the old card strongly suggests it was the SD card.

1 Like

Hi again,

I was really hoping not to need to reply, but it happened again, overnight my iotawatt stopped working.
Earlier today when I checked I was greeted with this webpage:

Without doing anything, I went and checked the unit and its green led was still flickering.
If it helps I have a video of it here

After that I then powered the unit off and took a copy of the flash card contents.
To do this I opened the unit, removed the flash card and placed the card in my laptop.
At this point I didnt attempt to power it back on or anything.
O have attached the log file…
iotamsgs.txt (5.0 KB)

I have since put the card back into the iotawatt assembled it and restarted, and it appeared to work.
This is without my doing anything to the SD card.

Any help is appreciated :slight_smile:

Thanks, Mark
PS. The SD card I am suing is still the one from a week ago which was a brand new sandisk card.

The message log shows the time being adjusted by anywhere from several minutes to an hour or more. That isn’t normal at all. You will recall that there was a similar problem on March 21. Now it seems much more frequent. This could be an issue with the IoTaWatt RTC (real-time-clock) or with the time server that is being used. Not being a big believer in multiple simultaneous problems, I suspect this has something to do with the reported problem, either directly or indirectly. Is your router providing time-services or is there any other alternate time server? IoTaWatt normally uses, which has been effective in eliminating time server issues, especially in Australia. I have never seen an RTC behave erratically like this, so I am suspecting the time server.

Also, could you setup your unit with the cover removed? Should (when) this happens again, rather than power cycle, could you restart by pressing the RST button next to the USB connector please? That will cause a restart but preserve the diagnostic trace in the message log, giving me some clues as to what it was doing.

My router is setup with the following… its a TP-Link Archer-C24
I think its values were just put in my the setup wizard that ran when I first connected it.

Apart from that I have a linux PC on my home network.
Its running Opensuse and syncing its time of the opensuse pool of ntp servers and powered on only during the day. I went back through its logs and it seems to be adjusting its time by about 1 to 1.5 seconds a day. The only time I saw a bigger just was when we had a daylight savings change and it recorded an hour jump in its logs in early April.

Is the clock displayed anywhere?
I was thinking it should be pretty easy to see if its off by a whacky amount.
I’ll keep an eye on the log via http://iotawatt.local/iotawatt/iotamsgs.txt?textpos=-10000
as from the last one I should see 3 or 4 sizeable jumps a day, that is assuming the reported adjustment in in seconds from the log as in …
6/12/22 02:24:45 timeSync: adjusting RTC by 2192

If the problem is still evident, after the first few reports, I’ll change my router to get its time from and then later my linux PC, to see if that has any impact on the problem.

I’ll also look to run the unit with the cover off to get you the trace as well.

Thanks, Mark