Green-Red-Red-Green LED Sequence

Yes, it’s in seconds. That’s the resolution of the RTC. Keep an eye on the adjustments, and please provide your hardware order number.

Thanks, my order number was #126097

Mark

Just an update … after the last mishap when I pulled the SD card, grabbed the log and posted it above.
After that I simply put the card back in and its been running fine again.
I have been keeping an eye on the log file for time adjustments, its been 8 days so far and there have been no time adjustments in the log at all.
iotamsgs.txt (6.5 KB)
There seems to be nothing much in the log at all apart from a wifi-reconnect when I power cycled my access point earlier tonight.
Strikes me as a little strange given the time seemed to vary wildly when the problem happened :frowning:
I am keeping an eye on my home network as well in the event that anything starts reporting whacky time.

Regards, Mark

1 Like

Sorry to dredge up an old thread.
Everything appears to have been running ok now for quite some time, however last night I noticed an RTC adjustment of “1743” in the log which I am assuming is nearly 1/2 an hour.

Is there any way of working out where the adjustment came from, ie if it was a whacky time server or anything?

My current iotawatt status looks like this …

Any my log currently has the following in it
iotamsgs.txt (6.7 KB)

Note that the tail of the log since the last incident is this bit

** Restart **

SD initialized.
6/13/22 04:11:21z Real Time Clock is running. Unix time 1655093481
6/13/22 04:11:21z Reset Reason: Power-fail restart.
6/13/22 04:11:21z ESP8266 ID: 440304, RTC M41T81 (68)
6/13/22 04:11:21z IoTaWatt 5.0, Firmware version 02_07_05
6/13/22 04:11:21z SPIFFS mounted.
6/13/22 14:11:21 Local time zone: +10:00
6/13/22 14:11:21 device name: IotaWatt
6/13/22 14:11:24 Connecting with WiFiManager.
6/13/22 14:11:27 HTTP server started
6/13/22 14:11:38 WiFi connected. SSID=brocolli, IP=192.168.1.16, channel=1, RSSI -62db
6/13/22 14:11:38 MDNS responder started for hostname IotaWatt
6/13/22 14:11:38 LLMNR responder started for hostname IotaWatt
6/13/22 14:11:39 timeSync: service started.
6/13/22 14:11:39 timeSync: adjusting RTC by 11
6/13/22 14:11:39 statService: started.
6/13/22 14:11:39 Updater: service started. Auto-update class is MINOR
6/13/22 14:11:40 dataLog: service started.
6/13/22 14:11:40 dataLog: Last log entry 06/12/22 22:28:30
6/13/22 14:11:40 historyLog: service started.
6/13/22 14:11:40 historyLog: Last log entry 06/12/22 22:28:00
6/13/22 14:11:41 Updater: Auto-update is current for class MINOR.
6/13/22 14:11:48 PVoutput: started
6/13/22 14:11:49 PVoutput: System New_Build, interval 5, freeload mode
6/13/22 14:11:49 PVoutput: Start status beginning 06/12/22 22:25:00
6/21/22 18:46:16 WiFi disconnected.
6/21/22 18:47:03 WiFi connected. SSID=brocolli, IP=192.168.1.16, channel=1, RSSI -62db
6/21/22 18:47:47 WiFi disconnected.
6/21/22 18:49:44 WiFi connected. SSID=brocolli, IP=192.168.1.16, channel=1, RSSI -62db
7/05/22 13:04:13 Updater: Invalid response from server. HTTPcode: -4
7/09/22 23:22:29 timeSync: adjusting RTC by 1743

I ran ntpscan and cant see anything untoward on my home network in terms if time services

image

The .114 addres I have discovered is my wifi garage door opener and over the last month appears to have had the correct time. I also checked my router (a TP link archer C24) and the time on it appears correct.

Regards. Mark

Here we go again :frowning:
I have been checking my setup almost everyday and things have just been working.
I did notice just 2 of these entries in the log from earlier this month, but apart from that all appeared ok

7/09/22 23:22:29 timeSync: adjusting RTC by 1743
7/11/22 20:22:29 timeSync: adjusting RTC by 197

The unit ran happily and did its 6 week routine restart on the 25th of June (if thats local time, it was yesterday)

7/25/22 14:22:29 timeSync: Six week routine restart.

Since the restart I have noticed these in the log

7/25/22 14:22:42 PVoutput: Start status beginning 07/25/22 14:20:00
7/25/22 22:23:34 timeSync: adjusting RTC by 1479
7/26/22 09:23:34 timeSync: adjusting RTC by 371
7/26/22 10:23:34 timeSync: adjusting RTC by 3332
7/26/22 11:23:34 timeSync: adjusting RTC by 3432

I cant see anything on my home lan that could be causing this (ie wanything braodcasting a sacky time or anything)
image

Complete log is attached
In the meantime, I’ll keep an eye on things

iotamsgs_Jun26th.txt (8.5 KB)

Regards, Mark

Hi again,

A further update, its taken a while since it last happened but my iotawatt appears to be non responsive again.
I checked last night and it appeared ok, its status webpage was working, I also looked at a graph of my solar output from yesterday which appeared ok (I also took a screenshot of the graph for reference).

I did notice that there were some further timeSync message in the log, they seemed to appear again around the 25th of July and have got more frequent over the past few days.
From looking at the log there is almost a pattern to them.

7/28/22 08:18:10 timeSync: adjusting RTC by 1614
7/28/22 09:18:10 timeSync: adjusting RTC by 3326
7/28/22 10:18:10 timeSync: adjusting RTC by 3003
7/28/22 11:18:10 timeSync: adjusting RTC by 3579
7/28/22 12:18:10 timeSync: adjusting RTC by 3278
7/28/22 13:18:10 timeSync: adjusting RTC by 3276
7/28/22 14:18:10 timeSync: adjusting RTC by 3430
7/28/22 16:18:10 timeSync: adjusting RTC by 3088
7/28/22 19:18:10 timeSync: adjusting RTC by 1658
7/29/22 08:18:10 timeSync: adjusting RTC by 1647
7/29/22 18:18:10 timeSync: adjusting RTC by 1078
7/29/22 21:18:10 timeSync: adjusting RTC by 1525

I think I have the latest log file it was left open in a tab on my browser.
iotamsgs_Jul30_3pm.txt (9.8 KB)

At the moment the unit is flashing with a green-red-red sequence.
It appears to be still connected to my wifi as I can ping it at its IP address 192.168.1.16 (fixed via a dhcp reservation on my router) but I cant ping it at iotawatt.local
Its web interface also currently seems down.

I have a short video of its led sequence on my google drive at …

In the previous post you mentioned this …

It is running with the cover off and I havent power cycled it or anything as yet.
If you do look in the log, the last restart was me taking the cover off late in the evening a few nights ago.
Is there any further instructions on what to do, ie is it just a momentary press of the RST button?

Thanks, Mark

Yes it is, then wait for it to completely restart before capturing the message log from the restart. It’s the trace that I’m interested in.

I tried pressing the RST button and the unit appears to reset.
From what I can see the blue led as well as the red/green one stop blinking for a second or so and the unit appears to come back up.
Its now flashing green-red-red and I cant seem to access it either by http://iotawatt.local/ or http://192.168.1.16 (which is its IP address).
I have a unifi access point and I can see that tis connected to my wifi

Is there anything else I can try to get the log/trace off it?
Apart from the RST press I havent done anything else such as remove the SD cad or power cycle it at the power point

Thanks, Mark

Sorry to dig up an old thread, but I’m having this exact issue. My unit is only a couple of months old. Is there anything I can do to help in the troubleshooting of the problem, or should I just get a replacement SD card?

For the past week or so, the web interface has not been available. It would just show

Not found: GET, URI: /

But my Home Assistant integration was still functioning, so I didn’t do anything with it. Last night, data stopped feeding into Home Assistant. I power cycled it twice, but nothing has fixed it. Home Assistant is not getting data, and the web interface just continues to show the above error message.

What was the order number?

Order number: 127642

I’ll send out a new card.