IotaWatt 2.4GHz WiFi connection

I have a strange problem; IotaWatt is connected to WiFi via a Unifi U6-LR AP, and uploads data fine to PVOutput, but for some reason, using the latest UniFi firmware, I cannot get the web interface and cannot be pinged but it is still obviously connected as data is uploaded and the light stays green. Power cycling doesn’t help. When I roll back to an older firmware, it works fine.
Any idea of the cause?

No. What is the version of the AP firmware?

The problem seems to be Unifi firmware 6.0.13 as well as 6.0.15, whereas 5.60.23 seems to work. It’s a very strange issue, as I can’t think of why it will connect, upload data, but can’t access the web interface or ping.

I’ve got a U7-LR in my network. I’m updating it to 6 now. Will see what happens. Sounds like it might have something to do with the UDP broadcast used in resolving the .local name. Have you tried accessing via the IP?

UPDATE: My UAP-AC-LR (U7LR) seems OK with firmware Tried using both LLMNR (Windows) and mDNS (Apple) zero-config protocols.

I’m accessing via IP address, as my normal connection is from my normal VLAN to my IoT VLAN; the firewall rules do allow connection in case you’re wondering, and it usually works, just not with 6.0.13 nor 6.0.15 (nor 6.0.23 EA); there is still no 6.0.18 for the U6.
I’m now suspecting the UniFi U6 firmware, as looks as if more than one 2.4GHz IoT device has broken connections, whereas my nanoHD appears to be working (although an earlier 6.0.x firmware also broke connection with some 2.4GHz devices).
Perhaps I need to sit out the updates for a while, but this may be of interest for those running the UniFi WiFi 6 series using 6.0.x firmware being unable to connect.