New Installation - Australia, Regional NSW

Here’s where we are:

  • Loads on the grid side of the blue phase were measuring incorrectly while the inverter was producing the blue phase voltage reference. It was both out-of-phase and lower than the independent grid side blue phase. Using derived reference for the grid side loads has resolved that problem and those loads are now measuring correctly.

  • The Blue phase VT is on the output side of the inverter. When the inverter is producing the power, it is a steady presumably clean 230V and the IoTaWatt is successfully monitoring power on the offgrid side.

  • When the inverter switches from supplying inverter power to providing grid power, the IoTaWatt is intermittently unable to accurately sense the voltage cycles and ceases to record power and voltage. These lapses can be seconds, minutes or hours in duration.

  • Attempts to obtain samples of the failing voltage signal have been unsuccessful because of the catch-22 that the IoTaWatt will not measure a signal it cannot sense.

My suspicion is that the inverter passes the grid through using solid-state switching that is altering the zero-crossing timing. I would need to see the actual failed voltage signals to be able to understand the sampling problem and determine if it is just a little outside of the parameters of the sampling routine, which possibly could be relaxed, or if there are multiple ambiguous zero-crossings that are defeating the fundamental way that the sampler works.

Another perhaps more remote possibility is that the multiple mechanical switches in the path of the blue phase are arcing or otherwise corrupting the clean grid sine wave. Limited plots of power anecdotally suggest that the problem could be triggered by larger current draw (the water heater?). Unlikely as this may be, a simple test would be to change the transfer switch while the problem is occurring to see if it goes away. Loads on the non-blue off-grid side will be measured with the wrong reference, but we would be interested only in seeing if the blue voltage reference freezes up.

I could figure this out given the ability to examine the equipment and modify the IoTaWatt configuration to extract more diagnostic information. There are unadvertised resources in the firmware that could be of help here. But being around the world and 15 hours out of phase makes doing anything like that very difficult and risky.

Thanks for the assessment.

What are my options for obtaining data sufficient for you to perform this assessment?

I need to think this one through (I need to wake up some more)

Flipping the manual transfer switch will briefly cut power to everything on the off-grid supply side (break before make), including the IotaWatt. So I expect it will reset. I don’t know if this will invalidate the experiment.

I could, if felt useful, temporarily power it via consumer grade UPS so that it can continue to operate while changing the transfer switch over.

The BLUE/Off-grid VT should then be powered directly from the grid and not the off-grid inverter. I need to validate it will in fact powered by the BLUE phase when the transfer switch is in the grid position (that power outlet was a new addition). It should be but needs validating.

Presumably this is not something which can be done remotely.

Thanks for the assessment and assistance, it’s appreciated. I didn’t mean for this to become an epic!

It complicated and involves manually changing the config file. I would try to keep everything working as is by switching one of the grid phases to derived, then use that input number to sample the blue VT as if it were a CT using the remaining grid phase as the voltage reference. The result should be the blue phase 120 degrees out of phase with the grid phase, but would be a whole cycle, just not starting and stopping at a zero crossing.

How long is the break? That’s usually milliseconds. The IoTaWatt may not drop. You could also power the IoTaWatt from the grid side.

OK, this is where that line drawing I asked for would come in handy. If the offgrid side is powered directly by the grid blue side, and doesn’t go through the inverter, then it won’t prove anything.

EDIT: Looking at your drawing of the transfer switch, it appears you are right and flipping back to the grid would also move the offgrid blue to the grid. So forget about that. The only option is to sample it as above.

Can you provide a link to the offgrid inverter docs?

Ah. I thought perhaps there might be some other source of data I could possibly obtain.

I can’t say. It’s a manually activated switch and requires quite some force to it move from the Off-grid position to the middle no power position and then to the Grid position (same in reverse).

So it will depend on how quickly I can make the two switches. They are both in the same direction but it could easily be 500 ms or more.

On the rare occasions when I do flip it over, I’m not normally doing it in a hurry, rather just making sure it’s done correctly.


That’s correct. When the transfer switch is moved to the grid position, then the off-grid inverter powers nothing.

I provided that diagram in this post:

I guess the thing missing from that transfer switch diagram is the AC input to the off-grid supply comes from grid phase BLUE.

EDIT - I see you saw that now.

It won’t be particularly illuminating. One of the Voltronic family of inverters, equivalent to the MPP 8048 MAX.

I tried to get a link on the supplier’s website but it’s just a nuisance link to Zoho log in.

The forum won’t accept me uploading the user manual as it’s a ~9 MB file (4 MB upload limit).

This is a link to the MPP version. The manual is identical aside from the logo on the cover.

@craig, @wattmatters
I have moved the post related to the WiFi issues to its own thread here:

It was getting harder to follow the electrical issues intertwined with the WiFi.

2 posts were merged into an existing topic: Wifi problems mesh router

An experiment. Here is the power trace for the Studio for yesterday:

Not a lot going on up there as it is currently unoccupied - just the fridge cycling on and off. The black line is general power outlets, red is the aircon circuits + lights and blue the oven/stove.

From midnight to a little after 8AM the off-grid inverter was supplying power. I had the voltage reference set for each (RED, WHITE, BLUE) to use the off-grid VT reference.

At 8:05AM my off-grid system cut over from supplying its own power to passing through grid power. Not long after that we can see the flat line appear, most obvious in the black line power trace.

So a little while later (~ 9AM) I changed the voltage reference for all three CTs to instead use a derived BLUE voltage reference (RED + 240°).

This resulted in a completely plausible power trace. Grid power is being passed though, so it’s not entirely surprising.

Later in the day (5:50PM) the off-grid inverter switched back from passing though grid power to supplying its own power. I made no change to the voltage reference set up, it was still using the derived BLUE voltage.

Even so, it did not seem to have any issue with reporting plausible power numbers. Now they will be out by a little because there would typically be a 10+ V difference between grid and off-grid voltages.

You can see the reported power numbers for the fridge jump up a little after 6PM, and that would be I presume because the IotaWatt is calculating power using a voltage reference which is a bit higher than it actually is (it will be circa 10 V higher).

Here is the power and PF traces for that black power line (WHITE) phase. PF for the other circuits likely won’t make much sense given power draw is so low:

I find this interesting.

If we compare the midnight to 8AM period with the 6PM to midnight period, there is very little difference in reported PF, even though the former used the VT reference and the latter the derived voltage reference.

I’m no engineer, let alone an electrical one, but does this evening power and PF trace suggest the off-grid inverter’s output maintains synchronisation with the grid (at least while ever the off-grid inverter has a grid input signal)?

It would seem, at least for these Studio circuits, to be a reasonable workaround until hopefully we can resolve the off-grid utility pass through voltage reference issue.

Naturally any time the grid power goes down (around here that’s a matter of when, not if) this means there won’t be any data but at least I have something.

However, I’ve replicated the same thing for the Mancave and unfortunately I don’t get the same outcome.

It should be almost be a replica of the Studio, with one circuit showing the regular power cycling of a fridge while the other circuits have very little consumption unless I’m down there doing stuff and/or have the aircon running. I need to do more investigation of the mancave set up.

All the circuits for the primary dwelling currently being monitored don’t use the off-grid supply so they are working well with their grid voltage reference.

I would like to cover some (if not all) of those primary dwelling circuits which are powered by via the off-grid system at some stage, hopefully by freeing up a CT or two by consolidating circuit monitoring for the Studio and Mancave.

Got a chance to do more testing. Rain interrupted the mowing.

I have a test load (plug in resistive element heater) which can operate at 800W, 1600W or 2400W (approx). Good for testing this stuff.

In the Mancave the RED and YELLOW circuits each supply power to GPOs on the north and south walls respectively. BLUE supplies aircon and lights.

On a north wall GPO (RED) with the heater I am seeing power numbers as expected. But on south wall GPO (YELLOW) I am not seeing anything. Tried all combinations of voltage reference. And the fridge is plugged into a south wall GPO.

So that explains why the fridge data is missing. Something is up either with how YELLOW circuit is connected in the main circuit board (unlikely given stuff actually works) or with the CT itself.

It is the only CT of the larger 100A type I have connected. So perhaps it’s not clipped on properly or is faulty. Don’t think I’ll be able to check it today but it’s on my hit list for tomorrow.

The BLUE Mancave aircon and lights data is also working as it should.

So just need to sort out what’s going on with the CT on Mancave YELLOW.

Here’s the power plot for mancave.

During this test the power was being supplied by the off-grid inverter. It had switched over earlier than normal today from passing through grid power because of a combination of battery being sufficiently charged, the rain came so likely we started importing power from the grid and it’s a weekday so the daytime tariff is more expensive than on a weekend.

The voltage reference is derived BLUE (RED + 240°).

The blue is lights, with the bump in the middle being when I tested the aircon.

The red is the resistive element heater as I ramp up its heat setting, then down. Then some testing on YELLOW (nothing) then a quick check on RED again. The low level RED consumption would be routers and other electronics on idle.

Zooming in on the heater test when plugged into RED and showing PF:

Can see PF went to 1.0 when the heater was on.

Hi @overeasy

If I were to gather some data on the mains voltage signal when the inverter is operating in Utility pass through mode using a tool such as this:

Would that help?

Apparently it can interface with a PC for capture of data.

Another win.

I checked the Mancave YELLOW CT this morning and it turned out the 3.5mm plug wasn’t quite clicked in the whole way. So that solves the mystery of why I could never see power on that circuit.

Since I was in behind the main circuit board again I figured I’d do a little reorg of the CTs to group the outbuilding CTs together, so this is the current set up:

Mancave showing the fridge cycling on YELLOW (black line) and the aircon on BLUE:

I am now getting power numbers from all off-grid CTs using the derived BLUE voltage reference (RED + 240°), no matter what operating mode the off-grid inverter is in.

So while it would be preferable to have the off-grid VT as the voltage reference for the off-grid circuits, at least I have a working solution and data.

I will monitor for a day or so and then probably consolidate the non-aircon circuits in the two outbuildings (Studio and Mancave) onto one CT, which will free up two CTs to assign to other circuits in the house.

1 Like

And so with the data now working, I tried the Home Assistant integration again.

I could not get it nor the HACS version to load before.

But today it accepted the IP address for the IotaWatt and loaded.

Screen Shot 2023-03-28 at 12.34.53 pm

With any luck it will be stable but I may still need to learn how to do REST API calls as an alternative. I’ll give it a while and see how it goes.


Integration with Home Assistant now seems stable.

The issue with the IotaWatt being unable to get a stable voltage signal from the off-grid VT has been narrowed down to specific scenario.

It only occurs when the off-grid inverter is in Utility pass through mode, but note:

The IotaWatt is unable to lock onto the VT’s voltage signal from either of

  • the Off-grid inverter’s output (which we knew before)
  • the BLUE phase AC input (this is new info)

I have tested swapping VTs and also the VT input ports on the IotaWatt to eliminate those as an issue. It’s the same no matter which VT or input port chosen.

Best guess at this stage is there is some noise being introduced by the off-grid inverter when in Utility pass through mode which is sufficient to cause the IotaWatt’s voltage sense waveform integrity threshold to fail. This noise is in both the up and downstream AC supply.

There’s also a remote possibility of higher frequency noise from the Utility causing interference/aliasing with the IotaWatt’s sampling rate (e.g. they use signalling in the 750 Hz range for load controls) but this seems unlikely as I would expect similar on the other phases.

In any case I have an oscilloscope on order so I will be able to capture waveforms from the lower voltage side of the VT to hopefully get a better handle on what’s going on.

I will share what I find.

Been learning a lot about this stuff along the way from various helpful souls.

An update on the voltage reference issue I’ve been experiencing:

I now have an oscilloscope and took some images of the waveforms from the low voltage side of the VTs.

Here is the waveform for WHITE phase for reference, each with a difference voltage scale:

The IotaWatt has no issue reporting the above WHITE phase voltage.

Here’s the waveform for the output from the off-grid inverter when it is passing through the BLUE phase:

The IotaWatt is unable to report this voltage.

Any thoughts or suggestions?

Happy capture more waveform images if it would help.


You need to zoom in on the zero crossings. It looks like there are some discontinuities there, but it is hard to see. My guess it is not passing the assumptions that Iotawatt makes about what
a zero crossing looks like.

Like this?

Yes, now put a tight window around that and see how many escape the window.

There are two signal quality checks. One involves “dirty” zero crossings where the actual crossing has so much noise it goes negative and positive multiple times within a few samples. I don’t believe that’s the problem here. The second is when the first half of the signal is significantly longer or shorter than the second. That’s what I suspect is going on here looking at the sag on the downward slope of each cycle.

You may be able to see that if your scope is fast enough and has memory to hold a complete cycle. I set my RIGOL DS1102 scope to 2 Volts/div vertical and 1ms/division horizontal. Set the trigger to upslope and the trigger level at zero. That captures the first crossing on the upslope and I freeze it there:

First Crossing

Then I scroll the ahead to 8.28 ms for the next crossing. Yours should be around 10 ms (50Hz)

Second Crossing

and the third:

Third Crossing
third is 16.6 - 8.28 =~ 8.3 ms later. A balanced signal. IoTaWatt has a tolerance of about 200 us difference between the two. My scope can’t really put a fine point on it, but it is good enough to indicate this signal is in compliance. See if you can generate the same metrics.

OK, thanks. I appreciate you checking it out.

I’ll capture more data later when I next get the opportunity but I just had a look at some of the captured waveforms using this suggestion. I can change the voltage and time scale to some extent with this function.

It may be this isn’t the best way to check and it’s better to have those settings in the scope to start with before capturing the data but at least it’s a start based on your suggestion.

Gap from down to up: ~10.20 - 10.25 ms

Gap from up to down: ~9.80 ms

Which suggests a duration difference of somewhere in the 400-500 µs range and that’s outside the 200 µs IotaWatt threshold you mentioned.

This duration difference between upper and lower half must vary at times because sometimes the IotaWatt manages to “lock onto the signal”^ for a while, then it loses it and flat lines. Yesterday afternoon was an example:

For most of the day (time preceding the left of the chart) when the inverter is passing through grid power the voltage signal shows that characteristic flat line behaviour.

At around 15:50 though it seemed to be able to latch on and manage to keep a lock on the voltage signal for most of the next hour and a half, with a few short spots it lost it.

At 17:25 the inverter ceased passing through grid power and switched over to generating all its own power from battery and any residual solar PV remaining. Hence the sharp drop in voltage to the inverter’s own output^^. The IotaWatt has no difficulty capturing the voltage data from the inverter’s own production.

I’ll capture some more data later on to validate but it’s looking like this is the issue.

Given this is it, then what are the options?

^ I’m using the term loosely, hope it expresses what I mean

^^ We are supposed to be 230 V grid supply here but as you can see that’s not actually the case.

There is really no electrical requirement that the signal be symmetrical. It is what it is and most energy monitors would probably have no trouble with it.

But IoTaWatt works differently. In order to measure 15 inputs, it samples each one individually for just one cycle, then moves on to the next. The power and voltage measured are time weight averaged into the 5 second averages. The problem is with that one sample.

The IoTaWatt has a single processor, but it does a lot of things. Most of the time it’s taking those samples, and when it does, any distraction for that 16.6 ms or 20 ms will cause it to miss samples and thus lose accuracy. It doesn’t happen often, but interrupts happen and are invisible to the high level firmware. The check for balanced wave is actually there to detect if an interrupt occurred so that the sample can be discarded.

I’ve not seen this circumstance where the actual wave is asymmetrical causing samples to be discarded for extended periods of time. That it’s supposed to be a grid signal is even more of a conundrum.

It appears that passing through the inverter is deforming the wave. I had thought that maybe relaxing the symmetry requirement a slight bit might be a remedy but 400ms would require doubling. It is solidly outside of the parameters of the sampling algorithm.